
 

Quick Guide to TestGen 

This document summarizes how to get started with TestGen and use its essential tools.   

TestGen is a powerful yet easy-to-use test generator and editor.  Pearson Longman makes 
available testbanks of ready-made questions that correspond with your textbook.  When 
you open one of these testbanks in TestGen, you can easily create a new test using these 
questions.  Or you can also add your own questions and edit as much as you like. 

For more detailed information about using TestGen, please refer to the User's Guide.  That 
manual is available on the TestGen CD-ROM ("TG5UserGuide.pdf" in the "Resources" folder) 
and in TestGen's Help menu, which is at the top of the program after completing the 
installation.   
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1) System Requirements 

Your computer must meet the following minimum requirements to install and use 
TestGen.  To Print TestGen tests, you also need a printer. 

 
 Windows Macintosh 
Computer type Intel 486 or Pentium series 

(I, II, III, etc.) microprocessor 
running at 150 MHz, with a CD 
drive and 15" color monitor 

Power Macintosh with a CD 
drive and 15" color monitor 

Operating system Microsoft Windows 98, Me, 
NT, 2000, or XP 

System 8.6 or 9.x with 
CarbonLib 1.5 or higher; or Mac 
OS X 

Available hard disk 
space 

15-20 MB 15-20 MB 

Random access 
memory (RAM) 

24 MB 
(64 MB for Windows 2000) 

24 MB 

Web browser* Microsoft Internet Explorer, 
Version 4 or higher, OR 
Netscape Version 4 or higher 

Microsoft Internet Explorer, 
Version 4 or higher, OR 
Netscape Version 4 or higher 

* Required only for viewing TestGen Help and TestGen tests over the Internet (using the TestGen plug-in). 

 

 

2) Installing and Starting TestGen 

Please Note: These installation instructions are for computers that do not 
have TestGen installed already.   

If your computer already has a version of TestGen installed, please refer to 
the Readme file ("Upgrading from an Older Version of TestGen") or User's 
Guide ("Compatibility with Earlier Versions"). 

 

For best results, please restart your computer before installing TestGen. 

 

2.1) Windows® Users 
 

1. Insert the TestGen CD-ROM into your computer's CD-ROM drive. 

2. Open My Computer.  To do so: 

• 

• 

On most computers, double-click My Computer on the desktop. 

On Windows XP computers, click Start and then click on My Computer. 

3. Double-click on the CD-ROM drive, which is illustrated by the  symbol. 

4. Double-click on "tgsetup.exe." 

5. Follow the directions on the screen to complete the installation. 
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Additional Notes: 

• During the installation, we recommend that you do not change the standard settings.  

• Should you select Full Install or Custom Install? 

• 

• 

• 

• 

Full Install: If you want to install both the TestGen program and a testbank 
of questions, select Full Install. 

Custom Install: If you want to install only the TestGen program or a 
testbank of questions, select Custom Install.  For example, select Custom 
Install if you want to use a new testbank and TestGen is already installed on 
your computer. 

• Once the installation finishes, the program will begin automatically. 

• To use TestGen after installation, the CD-ROM does not need to be in the CD-ROM drive. 

• To open TestGen after first use, click Start > Programs > TestGen 5 > TestGen 5. 

 
2.2) Macintosh® Users 
 

1. Insert the TestGen CD-ROM into your computer's CD-ROM drive.   

A TestGen window should open.   

If this window does not open, double-click on the CD icon on the desktop. 

2. Double-click on "TestGen_Installer." 

3. Follow the directions on the screen to complete the installation.   
 

Additional Notes: 

• During the installation, we recommend that you do not change the standard settings.  

• Should you select Easy Install or Custom Install? 

• 

• 

Easy Install: If you want to install both the TestGen program and a testbank 
of questions, select Easy Install. 

Custom Install: If you want to install only the TestGen program or a 
testbank of questions, select Custom Install.  For example, select Custom 
Install if you want to use a new testbank and TestGen is already installed on 
your computer. 

• Once the installation finishes, the program will begin automatically. 

• To use TestGen after installation, the CD-ROM does not need to be in the CD-ROM drive. 

• To open TestGen after first use, find the location where the program was installed, and 
then double-click on the "TestGen" application. 

 

                                              Updated: 7/23/03 3



 

2.3) Selecting a password 
 

The first time you use TestGen, a window like the Password Registration Screen (below) 
appears to allow you to set a password.  If you create a password, it must be entered each 
time you use TestGen. 

• To select a password, type the same password in the first two password fields and enter 
a password hint , and then click on the OK button . 

• If you do not wish to protect TestGen with a password, click on the No Password 
button . 

• If you forget your password, follow the directions in the User's Guide ("Password"). 

 

Password Registration Screen 

 
 
 

3) Creating a Paper Test Based on a Testbank 

There are three main ways to create a paper test with TestGen: 

1. Create a test by dragging and dropping selected testbank questions (questions that 
come with the CD-ROM) into a new test.  This method—described in Section 3 (this 
section)—allows you to select which questions you want to include in a new test. 

2. Use the TestGen Wizard.  This method—described in Section 4—creates a new test in a 
more automated way.  You may choose the specific questions in a new test or allow 
TestGen to select questions randomly. 

3. Create your own new questions to add to a test, or to create a completely new test.  
This method is described briefly in Section 3.9.  Please refer to the User's Guide for 
more information. 
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3.1) Start TestGen 

 

Windows users: Click Start > Programs > TestGen 5 > TestGen 5. 

Macintosh users: Find the location where TestGen was installed and double-click on 
the "TestGen" application. 

 
 
3.2) Open a testbank 

• A testbank file may open automatically (its contents appear on the left side of the 
screen). 

• If no testbank file opens, click File and then Open Book, click on a testbank file in the 
"TestGen5" folder, and then click on the Open button. 

 

When a testbank opens, the Start a New Test Screen appears (below). 

 
3.3) Choose a test type 

Click A paper test , and then click No when given the option to use the TestGen Wizard.  
(To create a test using the TestGen Wizard, see Section 4.)  A Test window will open on the 
right side of the screen. 

Start a New Test Screen 

 
 

Please Note: To create a test other than a paper test, please refer to the 
User's Guide. 
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3.4) View testbank outline (Outline View) 

The Outline View of a Testbank Screen (next page) shows a testbank outline.  The top level 
of the outline contains chapters, or units.   

• To expand a unit to see questions and/or sections within a unit, click on the arrow next 
to the unit name (for example, ).  

• If there are sections within a unit (for example, "Achievement Test 1" in the Testbank 
Window (Outline View) Screen, below), click the arrow next to the section name to see 
questions within that section. 

• Test questions (for example, ) are at the lowest level of a testbank outline.  The 
content of the questions cannot be viewed in this Outline View, but can be viewed in 
Question View (see Section 3.5). 

 

Testbank Window (Outline View) Screen 

 
 
 
3.5) View testbank questions (Question View) 

To view the content of questions in Question View: 

• Click on a unit title (its background will turn blank) in the Testbank window. 

• Click on the Switch View button , which switches between Outline View (see Section 
3.4) and Question View. 

• In Question View, you can only view questions from one unit at a time.  To view a 
different unit: 

Click the Switch View button  to return to Outline View. • 

• 

• 

Click on a different unit title (its background will turn blank) in the Testbank 
window. 

Click the Switch View button  to return to Question View. 

                                              Updated: 7/23/03 6



 

3.6) Transfer questions from testbank to test (Simplest Method) 

Click on a question (in either Outline View or Question View) from the Testbank window (for 
example, ), and then use the mouse to "drag and drop" it into the Test window . 

Sample Testbank Window and Test Window Screen 

 
 
 
3.7) Transfer questions from testbank to test (Other Methods) 

 

Transfer 
questions using 
the Add to test 
button  

• To transfer a single question: Click the question you want to 
transfer, and then click on the Add to test button . 

• To transfer more than one consecutive question: Click on the 
first question, hold down the "Shift" key, click on the last 
question, and then click on the Add to test button . 

• To transfer more than one non-consecutive question: Hold 
down the "Control" (or "Ctrl") key, click on each question you 
wish to include, and then click on the Add to test button . 

Transfer 
questions 
randomly 

• In Outline View, click on a unit or section title.  In the "Number 
of items per selection" field , enter the number of questions 
you want to transfer, then click on the Add to test button . 

• You can also select more than one unit or section.  The number 
in the "Number of items per selection" box  determines how 
many questions are randomly chosen from each unit or section 
selected. 
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Please Note: If you make a mistake transferring questions using the Add 
to test button , don't worry!  Click on the question in the Test window 
and then click Edit > Undo Transfer.  To delete a question anytime, click 
on the question in the Test window and then click Edit > Delete. 

 

3.8) Edit a test question (Optional) 

• Double-click on the question (in Question View) you want to edit. 

• Make your change and then click the "X" in the upper right corner of the window to save 
and close the question window. 

• The edited question appears in the Test window. 

 

Please Note: If you edit the question in the Testbank window instead of in 
the Test window, then you will not need to make the same edit each time 
you use that question in a test. 

 
 
3.9) Add your own questions (Optional) 

Click the top of the Test window to make it the active window.  Scroll down to the bottom of 
the test page and click the last item on your test.  Click Edit > Add after to open the 
Question Editor (not shown). 

Click in the "Question" text box and type your question.  Type the answer choices in the 
lettered fields.  Click the box to the left of an answer choice to mark the correct answer.  
When you are done, click File > Close – Save Changes.  Your new question will appear on 
the test page. 
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3.10) Print the test 

• To print your test, click File and then Print at the top of the TestGen window. 

• To print an answer key with your test, click the checkbox next to "Print answer key"  
when you see the Printer Settings Screen (below). 

 

Printer Settings Screen 

 
 

Please Note: We recommend that you leave the "Numbers of forms" at the 
standard setting, "1."  That way each printed copy of the test will display 
the answer choices and correct answers in the same order. 

 

3.11) Save the test (Optional but recommended) 

Click the top of the Test window to make it the active window.  Click File > Save.  Enter a 
name for this test (notice that the test will be saved to the "tests" folder inside the 
"TestGen5" folder) and click Save.  On Windows computers, test files have the .TST 
extension. 
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4) Creating a Test with the TestGen Wizard 

This section of the Quick Guide demonstrates the five steps to create a paper test with the 
TestGen Wizard.  At the end of each step, click on the Next>> button.    

4.1) Step 1: Enter a test name 

• Open TestGen. 

• At the top of the program window, click File and then TestGen Wizard... . 

Selecting the TestGen Wizard Screen 

 
 

• On the Step 1: Enter a Test Name Screen (not shown), type a test name of your 
choosing (e.g., Final Exam), and then click on the Next>> button. 
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4.2) Step 2: Select one or more chapter(s) 

• Click on the chapters, or units, from which you wish to select test questions.   

• For example, the Step 2: Select One or More Chapter(s) Screen (below) shows that 
Units 1, 2, 5, and 7 have been selected. 

 

Step 2: Select One or More Chapter(s) Screen 

 
 
• To select more than one consecutive unit, click on the first unit, then hold down the 

"Shift" key, and then click on the last unit. 

• To select more than one non-consecutive unit, hold down the "Control" (or "Ctrl") key, 
and then click on each unit you wish to include. 
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4.3) Step 3: Choose a selection method 

From the units selected in Step 2, you may choose test questions randomly or deliberately 
from a list. 

• To choose questions randomly, choose "Select questions randomly" when you reach the 
Step 3: Choose a Selection Method Screen (below), and then continue reading at 
Section 4.4.1. 

• To choose questions deliberately from a list, choose "Select specific questions from a 
list" when you reach the Step 3: Choose a Selection Method Screen (below), and then 
continue reading at Section 4.4.2. 

 

Step 3: Choose a Selection Method Screen 
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4.4) Step 4: Choose questions 

 

4.4.1) Select questions randomly 

• Click on an option in the "Choose randomly by" field .   

• The three options are Question Type, Chapter, and Skill (e.g., vocabulary). 

• The example in Step 4: Choose Questions Screen (Random Questions) shows 
choosing by Question Type. 

• Each Question Type has a certain number of questions available.  To select the number 
of questions to include for each Question Type, click on each 0 (zero) in the "Select" 
column (for example, ), and then type a number. 

 

Step 4: Choose Questions Screen (Random Questions) 
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4.4.2) Select specific questions from a list 

If you choose to select specific questions from a list, all of the questions from the units 
selected in Step 2 will be shown.  In the list, notice that: 

• Each question is listed with its Question Type.  For example, "SA" is short answer . 

• Each question has a numeric code , which represents the question's location in the 
testbank.  

• Each question is shown , but the answer choices are not. 

 

Step 4: Choose Questions Screen (Specific Questions) 

 
 
• To select more than one consecutive question, click on the first question, then hold 

down the "Shift" key, and then click on the last question. 

• To select more than one non-consecutive question, hold down the "Control" (or "Ctrl") 
key, and then click on each question you wish to include. 
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4.5) Step 5: Review the test summary and build the test 

• When you complete Step 4 (see Section 4.4), a test summary will appear (see Step 5: 
Review the Test Summary and Build the Test Screen, below).  Click on the Finish button 
to build the test and finish with the TestGen Wizard. 

 

Step 5: Review the Test Summary and Build the Test Screen 

 
 
• Your selected questions will appear in a Test window.  You can add, delete, modify, or 

rearrange questions in the Test window before you save and/or print.  For information 
about creating your own test questions, please refer to Section 3.9, or see the User's 
Guide for more detailed information. 

• Important: We strongly recommend that you save the test at this point.  At the top of 
the TestGen window, click File and then Save.  Name the file and then click on the 
Save button. 

  

Please Note: The TestGen Wizard scrambles the order of test questions.  If 
you wish to keep questions in order, click Tools and then Sort…, and then 
select "Smartsort by Testbank Order." 
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4.6) Printing your test 

• To print your test, click File and then Print at the top of the TestGen window. 

• To print an answer key with your test, click the checkbox next to "Print answer key"  
when you see the Printer Settings Screen (below).   

 

Printer Settings Screen 

 
 

Please Note: We recommend that you leave the "Numbers of forms" at the 
standard setting, "1."  That way each printed copy of the test will display 
the answer choices and correct answers in the same order. 

 
 
 

5) Frequently Asked Questions 

5.1) Does the TestGen CD-ROM need to be in the computer after installation? 

5.2) TestGen Terms: What do "testbank," "book," and "test" mean? 

5.3) How do I search for specific information in a testbank? 

5.4) How do I make sure "All of the above" is the last answer choice for a 
question?  

5.5) How can I change the order of test questions? 

5.6) How can I contact Technical Support? 
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Answer 5.1: No.  Once the installation is complete, the CD-ROM does not need to be in the 
CD-ROM drive.  

Answer 5.2: A "testbank" is the full list of questions that comes with the TestGen CD-ROM.  
"Testbank" and "book" mean same thing in TestGen terminology.  From the "testbank" or 
"book," many "tests" can be created. 

Answer 5.3: On the menu bar at the top of the program, click Tools > Search…. 

Answer 5.4: Double-click on a test question and then click on the lock icon next to the last 
answer choice.  For example, in the Sample Question Showing a Locked Answer Choice 
Screen (below) the closed lock beside answer choice "d" indicates that the placement of this 
answer choice will not change. 

Sample Question Showing a Locked Answer Choice Screen 
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Answer 5.5: There are two main ways to change the order of test questions automatically: 
sorting and scrambling. 

• To sort test questions in a specific way, click on the "Sort" icon . 

• To scramble test questions into random order, click on the "Scramble" icon . 

Sample Test Screen Showing Sort and Scramble Buttons 

 
 

Please Note: If you scramble test questions into random order, the 
"question type headers" (directions) will be repeated every time there is a 
change of question type.  There are two ways to prevent this.  Click on the 
"Sort" icon, and then:  

• Choose SmartSort by Question Type. 

• Deselect the "Include question type headers" box, and then click OK. 

 

Answer 5.6: Within the United States, call 1-800-677-6337 between 9:00 and 18:00 (New 
York time), Monday through Friday.  You can also get support by filling out the web form 
located at: 

http://247.pearsoned.com/mediaform.html 

Our technical staff will need to know certain things about your system in order to help us 
solve your problems more quickly and efficiently.  If possible, please be at your computer 
when you call for support.  You should have the following information ready: 

• product and title and product ISBN  

• computer make and model  
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• RAM available  

• hard disk space available  

• graphics card type  

• printer make and model (if applicable) 

• detailed description of the problem, including the exact wording of any error messages 
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